How can I tell if my device has a firmware update error?

This article applies to the CTR35 and the MBR90.

Symptom:

The Firmware update results in a failure to complete the update process on a CTR35 or MBR90

Cause:

Firmware versions 3.0.4 to 3.0.7 on the CTR35 and Firmware versions 1.8.1 and earlier on the MBR90 require Signed Firmware from CradlePoint Support to update to a newer version.

Resolution:

Upgrading past the 3.0.x firmware versions requires a signed firmware file specific to your device that can be generated by a Technical Support Representative. To get this file, please email support@cradlepoint.com with the MBR90 or CTR35’s serial number and MAC address (these can be found on the label on the bottom of the device).  Also include your First and Last Name, as well as a good email address for the Tech Support Rep to send the file to you.


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